Home » Topics » General Support » ACFW in pagebuilder

ACFW in pagebuilder

ACF Widgets Support General Support ACFW in pagebuilder

This topic contains 2 replies, has 3 voices, and was last updated by  Daron Spence 6 months, 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #96719

    Hi Daron,
    I downloaded ACFW and I’d like to use it inside a page builder (Page Builder of SiteOrigin).
    I’m going to create a custom widget,with 2 text fields and 1 img (as showed in your demo).
    Then I’m trying to use pagebuilder and put widget inside a column.
    I execute all steps as described in the hook but I do not display the values in the front-end.
    I think that problem is related to variabile $acfw in the template file .php
    <?php the_field( ‘titolo’, $acfw ); ?>
    because if I print it, it shows widget_widget_0-0-0.
    If I hardcoded something like widget_acf_widget_19-2′ instead of $acfw, it works fine because both text fields and image are showed.

    If I use the widget in Widget section and put it in header, footer or sidebar it works fine.
    Is There a way to enable ACFW also inside page builder?
    Can you give me any suggestions to overcome this limit, please?


    Mat Stillo

    Hi there,

    I’d like to bump up this question again if I can. I’m having the same issues. Being able to use ACFW in Pagebuilder would make it an enourmously powerfull & appealing plugin for building a CMS, so I’l love to crack this



    PS if it helps, whenever I add the wdget to a PageBuilder layout, it displays all the fields I have created and added, but above that I still get the message ‘you have not created any fields yet’. Any content I add to the fields below is then not displayed. It is accessing the template file just fine though.


    Daron Spence

    Sergio and Matt,

    I know this is months too late and I apologize! I’m usually pretty good about not missing these.

    I wanted to let you know that I’ve now gotten your request and I’m looking into solutions.

    Unfortunately, this is a long running issue with ACF and page builders, but I’m still looking for solutions.


Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.